Naming Conventions

Hi guys,

Could you share your rig naming conventions?
[ul]
[li]Breakdown of ways you use layers
[/li][li]Use prefix/suffix to identify node types or cust attrs?
[/li][li]Order, do you use part_side_type (heel_R_point), type_side_part (point_R_heel) etc?
[/li][/ul]
At Crytek each guys has his own personal naming conventions, some coming from other places they worked that had rigid conventions. However, I want to change this in the future.

We have a few different conventions depending on what the exported result is; our layer setup for a rig is as follows:

[ul]
[li]skel_lyr - the exported animation hierarchy
[/li][li]skins_lyr - the render mesh for preview purposes, we don’t export this from an animation scene
[/li][li]flags_lyr - the main layer for rig controls (“flags”)
[/li][li]flags_secondary_lyr - auxiliary controls for secondary animation (cloth, pipes, etc)
[/li][li]markers - attach points for external objects, effects, etc. I’m not sure we actually export these from an animation file.
[/li][li]collision - collision geo, again for preview.
[/li][/ul]

Naming convention we set in tools and it’s pretty simple, albeit inconsistent. <*side_type_*type_*index_or_descriptor>, asterisks are optional. Examples:

[ul]
[li]l_forearm <side_type>
[/li][li]l_index_finger_1 <side_type_type_index>
[/li][li]spine_1 <type_index>
[/li][li]pipe_null <type_descriptor>
[/li][/ul]

I’d suggest letters instead of numbers for index. i.e. - spine_A, spine_B.

Then you don’t get an accidental Maya rename of a duplicate object screwing with the number scheme.